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TRADER USER GUIDE  

Title 1 Disclaimer 

CEEGEX Trader Client offers a great deal of flexibility to exchanges to configure new products. 

Considering the generic nature of the CEEGEX Trader Client, and thus this manual, some 

products and functionality described in this document may not be available to you. 

The screenshots used in this manual are of non-existent configurations. Products displayed in 

the various screens may not apply to your exchange and use imaginary values. Please consult 

your exchange to see what products are available. 

  



   

 

Title 2 Introduction 

This guide is intended for CEEGEX Traders. 

Assumption throughout this guide is made that the reader has full authority and permission to 

perform the actions required. 

2.1 Installation 

This section describes the installation process for the GlobalVision Front-End. Download the 

GlobalVision automated installation from CEEGEX website and double-click on it to start the 

installation. 

 On the welcome screen, click Next. 

 Read through the licence agreement. If you agree to the terms, select "I accept the 

terms of the licence agreement" and click Next. If you do not agree to the terms of the 

licence agreement, you will not be able to continue installing GlobalVision. 

 The installation process displays the installation directory. 

If you do not want to install the Front-End to the displayed directory, click Change to 

open the change directory window where you can select the directory you want to install 

the software to. When you have selected a directory, click OK to continue with the 

installation process. 

 Click Next. 

 The installation process is now ready to install the software. Click Install to install the 

software, or click Back to step back through the installation process if you want to 

change any of the settings. 

 When the software has been installed, click Finish to close the installation process. 

Trayport GlobalVision Exchange Trading System (8.11.) is using the following five ports that 

need to be open on your firewall: 80, 443, 11997, 11995, 12003. 

2.2 Getting started 

2.2.1 Logging in 

Open the GlobalVision Front-End, either by double-clicking on the icon on your desktop, or by 

selecting the GlobalVision option from the Windows Start Menu. Depending on how your 

system has been configured, any one of the following might happen when you start 

GlobalVision: 

2.2.1.1 GlobalVision displays a message telling you that it is connecting 

GlobalVision has been configured to connect to your account automatically every time you 

start the Front-End, and has stored your username and password so that you do not need to 

type them in every time you start GlobalVision. 

  



   

 

2.2.1.2 GlobalVision prompts you for a username and password 

Type in your username and password and click Login.  

 

Be aware that you have a maximum of three attempts to enter the correct password. After the 

third invalid attempt your User name will be blocked from access until the system operator 

resets your User name. In any entry screen, when you click Cancel, it will not be counted as 

an attempt. 

2.2.1.3 Nothing (GlobalVision just displays a blank grid) 

You will need to create an account (if one has not already been created for you), and connect 

to it. 

If your account has not been defined, GlobalVision displays the Account Properties Dialog: 

 

 



   

 

 

2.2.2 Failed login 

If during the submission of a password a wrong response is used to connect, Trading System 

will deny access. A warning will be displayed, informing about the failure. 

2.2.3 Loading a Workbook 

Once you have connected to your account, you must load a Workbook before you can trade. 

Workbooks contain the Work Sheets that you use to enter orders and make deals. 

Your account may be configured to load a particular Workbook automatically when you 

connect, but if no Workbook loads, do the following: 

 Go to File → Open... (Ctrl+O) or you can use the  button 

 Type in the location of the Workbook you want to load 

 Click OK. 

You can set your default Workspace/ Workbook in the Options menu → General tab. 

 

 

 



   

 

2.2.4 Logout 

Select the option Exit from the file menu, or use [ALT-F] & [ALT-E] respectively. 

Alternatively you can click on the Windows X in the upper right corner of the CEEGEX Trader 

Client to terminate the connection. 

Title 3 Menu bar 

3.1 File Menu 

3.1.1 Open… 

Brings up a dialog box in which you can type the location of a Workbook to open. You can also 

use the  button. 

3.1.2 Reload Workbook(s) 

Reloads all the Workbooks that are currently open so that the Workbooks revert to the last 

saved version. 

3.1.3 Workspace 

 Load: loads a saved set of global settings, including the currently open windows and 

their sizes and onscreen positions. 

 Save: saves current workspace 

3.1.4 Exit 

Logs you out of your account, and closes the GlobalVision Front-End. Please note that logging 

out may cause your orders to be withheld, depending on your selected configuration setting. 

To configure what GlobalVision should do with any orders you have in the system when you 

log out, go to Tools → Options and select the Connections tab. 

3.2 Edit Menu 

Edit menu contains commands relating to the handling of information, i.e. Cut, Copy and Paste, 

Undo and Redo commands. 

3.3 View Menu 

3.3.1 Window linking and channel options 

Linked windows save space by showing information that would normally require several 

windows. Select a channel to allow dynamic windows to be linked to a Worksheet. 

 

 

http://en.wikipedia.org/wiki/Command_%28computing%29
http://en.wikipedia.org/wiki/Cut_and_paste


   

 

3.3.1.1 To use dynamic windows for Market Depth, Deals and Order Management do the 

following: 

Right click on instrument and select Linked → View Recent Deals, Market Depth or Order 

Management. 

 

If you move between instruments and contracts you can see the dynamic changes. 

3.3.1.2 Using channels 

An example for using channels: 

1. Right click on instrument and select Linked → View Market depth.  

2. It will be linked to channel 1. 

 

3. Go to View → Channel and select channel 2. 

 

4. Right click on an instrument and select Linked → View Market depth. 

 
5. It will be linked to channel 2. 



   

 

6. Only the second market depth window is assigned to channel 2 changes. The first market 

depth window does not change. 

  



   

 

3.3.2 Deals  

There are number of tabs in the Deals Window that display different deal categories. You can 

always view current deals as well as choose to display unconfirmed or deleted deals by 

selecting any of the tabs above the deal list. 

Open Deals window by clicking on the  icon on the right side of the menu bar or choose 

Deals in View menu. 

On the left hand side of the window you can modify the settings of instruments, dates and 

traders shown in the list. 

 

To customize columns shown in Deals window go to View → Columns toolbar menu. 

In order to save your settings navigate to the File → Save to Favourites window from the menu. 

3.3.3 Order Management 

The Order Management Window provides advanced search capabilities, allowing you to 

manage orders across multiple markets easily, and see all the details related to your orders 

and deals in the markets that you are interested in. The Order Management Window is live so 

any orders inserted, updated, dealt, or deleted will be reflected instantly in the market.  

To open Order Management click on the  icon on the upper right menu bar. 

 

You can also see historical information about orders that have been dealt, cancelled, or 

updated in the market by viewing the order history. 



   

 

 
To save your settings got to File → Save to Favourites  

3.3.4 Basket 

You can collect items that you want to buy in the Deal Basket, and then later purchase them 

all together in one transaction. The utilization of basket dealing is mostly used by those who 

trade with several instruments on more than one market. 

To use the Deal Basket: 

 Right-click on an order and select Add to Basket. GlobalVision displays the Deal 

Basket. 

 Repeat this for every order that you want to deal. If one of the orders in your basket 

changes, it is automatically removed from the basket. You can manually remove an 

order from the basket at any time by highlighting it and clicking Remove Price. 

 If you want to set the basket to deal as many orders as it can, even if not all of the 

orders are available, select Execute each order independently. By default, this option 

is not selected, so that by default GlobalVision does not deal any orders unless it can 

deal all the orders. 

 When you are ready to deal the basket, select I confirm the Deal Details are correct, 

and click Deal. 

In the following example Execute each order independently is not selected, so the basket will 

only be dealt if all two individual orders can be dealt. 

 

 



   

 

3.3.5 Order Book 

It shows either all the orders you have in the market, or the orders you have entered for a 

specific instrument. In the Order Book you can add, delete and withhold orders. 

You can use the Order Book for example to change all your prices in the system by the same 

amount. You can also use it to firm or withhold all your prices simultaneously. 

To open the Order Book, do one of the following: 

 go to View → Order Book. 

 click on the Order Book icon  on the menu bar. 

3.3.5.1 Using the Order Book to add orders 

To add order in the Order Book you can either: 

 right-click → “Add Order” or 

 double-click on any cell 

After selecting the instrument the same window will appear when adding an order in the 

Hungary worksheet → see Section 6.1. 

→  

 

3.3.5.2 Firming multiple orders simultaneously 

To make multiple orders firm: 

 select the orders you want to firm by holding down Ctrl and click on each order that you 

want to firm 



   

 

 When you have selected all the orders that you want to firm, right-click on the selection 

and select Firm Order. 

 

3.3.5.3 Showing and hiding columns 

To ensure the Order Book only shows you the information that you need, you can hide columns 

that you are not interested in. To do this, click on the right hand edge of the column heading 

of the column you want to hide, and drag the column's right border across to the left until the 

column disappears. If you have hidden some of the columns in the Order Book, then you can 

easily display those columns again by clicking on . 

 

3.3.5.4 Increasing or decreasing prices 

You can increase or decrease one or more prices by selecting the ones that you want to 

change and clicking the appropriate Market Maker button on the top row. 

 

 → increases the selected prices by the displayed amount. 

 → decreases the selected prices by the displayed amount. 

Each market maker button has a drop-down arrow next to it. Click on this to increase or 

decrease the selected prices by a different multiple of the instruments’ stepping. 

Please note the prices will be updated immediately after clicking on the bottom, no confirmation 

message will be shown. Also when choosing a multiplier the certain order will be updated 

immediately by the selected multiplier. 



   

 

For example, if you select the x5 setting on the up arrow button, and the selected price is for 

an instrument with a stepping of 1, then this will increase the selected price by 5. 

 

3.3.5.5 Narrowing or widening prices by a certain amount 

If you have orders in the system on both the bid and ask sides, then you can use the Order 

Book to narrow or widen the gap between these prices, by selecting the ones that you want to 

change and clicking on one of the following Market Maker buttons: 

 → narrows the gap by simultaneously increasing any selected bid prices and 

decreasing any selected ask prices. 

For example, if you have selected one bid and one ask, and the instrument has a stepping of 

1, then clicking this button will increase the bid by 1 and decrease the ask by 1 (therefore 

narrowing the spread by 2). 

 → widens the gap by simultaneously decreasing any selected bid prices and 

increasing any selected ask prices. 

For example, if you have selected one bid and one ask, and the instrument has a stepping of 

1, then clicking this button will decrease the bid by 1 and increase the ask by 1 (therefore 

widening the spread by 2). 

Each market maker button has a drop-down arrow next to it where you can select a different 

multiple to widen or narrow gap between the selected bid and ask prices. Please note the 

prices will be updated immediately after clicking on the bottom, no confirmation message will 

be shown. 

3.3.5.6 Withholding, firming and deleting 

You can use the Order Book to withhold, firm and delete multiple orders simultaneously. 

 → selects all your orders currently shown in the Order Book 

 → firms the currently selected orders 

 → withholds the currently selected orders 

 → deletes the currently selected orders. 

3.3.5.7 Deal Ticker 

You can open a scrolling deal ticker to see details of deals as they take place. The details of 

each deal are displayed in a small rectangular deal card, which scrolls across the screen from 

right to left, as shown by the example in the figure below. 



   

 

3.4 Format 

Under Format menu you find the following commands: Autosize Rows and Columns and 

Freeze Rows and Columns. 

  



   

 

3.5 Tools 

3.5.1 Account 

3.5.1.1 Login/ Logout 

You can logout and login from the Tools/ Account menu. 

3.5.1.2 Properties 

Shows account information such as Account Name and IPTS. You can connect to Chat Server 

automatically when you login and also set which workbook should be loaded when connecting. 

 

3.5.2 Withdraw prices 

Allows you to withdraw all your orders from the market, or delete your orders altogether. Please 

note that you cannot undo this action once it has been carried out. 

  



   

 

3.5.3 Options 

3.5.3.1 General Options 

 

1. Maximum iterations for Calculations  

Limits the way in which GlobalVision creates implied orders, such as interproduct and 

interperiod spreads. To turn off the display of implied orders, set this value to 0. This setting 

only applies to implied orders that have been generated natively by GlobalVision. 

2. Default Workspace/Workbook 

Select this option and specify a filename to configure a default Workbook or Workspace to load 

every time you start the GlobalVision Front-End. 

3. Save Workspace on exit 

Select this option to configure the system to automatically save the current Workspace when 

you close the Front-End. If you select this option, then every time you close the Front-End, the 

last loaded Workspace will be overwritten with the current state of the Front-End.  

4. Show price entry keypad 

Select this option to display the numeric keypad in the Price Entry Dialog as shown in the figure 

below. 
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5. Default to best price 

When this option is selected, and you add an order, the price value field in the Price Entry 

Dialog will default to the current best price on the side of the market you clicked on when 

adding the order. When this option is not selected, the price value is blank on opening the 

Price Entry Dialog. If there has been no order for the instrument yet the best price will be the 

previous best price. 

6. Swap price/ quantity 

This option swaps the position of the price value and quantity fields in the Price Entry Dialog. 

When this option is selected, the quantity field will be displayed first. When this option is not 

selected, the price value will be displayed first. 

7. Allow direct price entry 

Select this option to turn on direct price entry, a special shortcut that allows you to submit 

orders more quickly by typing the price straight into the Work Sheet. 

8. Good Till Date is absolute time 

Changes the way you specify the expiry time for orders submitted on a Good Till Date basis.  

When this option is not selected, you specify the expiry time as an offset against the current 

time (for example, you can specify that the order should expire 10 minutes in the future). When 

this option is not selected, you will not be able to submit an order with an expiry time more than 

24 hours in the future. 

 

 



   

 

9. Warn when crossing the market 

Front-End will display a warning message if you attempt to submit an order that crosses the 

market. This is designed to prevent you from accidentally submitting an order at the wrong 

price value. 

10. Show only workbook name in window title 

Configures how the Front-End should display the Workbook details in the title bar and on the 

Microsoft Windows task bar. If you select this option, then the title bar and task bar will only 

display the Workbook's name, omitting the server address details. Please note the above listed 

settings will be stored on the modifier’s local system. 

3.5.3.2 Connection  

Specifies what GlobalVision should do if you are disconnected from the server for any reason. 

You are recommended to set the default action to withhold all your orders, and select Show 

notification, so that you know that you have lost your connection. 

 

3.5.3.3 Price Colour Options 

Select the type of order you want to change from the list on the left, and select the text colour 

from the Text drop-down on the right. 

3.5.3.4 Appearance Options 

You can change default font, bid and ask background colours. Setting different colours to bid 

and ask order makes adding an order more perspicuous. 



   

 

 

It will be shown in the following way in the Add Order window: 

 



   

 

3.5.3.5 Chat Options 

You can set message appearance and message arrival. 

3.5.3.6 Deal Confirmation 

1. Manual Deal Entry Confirm 

When this option is selected, a confirmation window showing the deal details is displayed when 

you click OK on the Add Deal Dialog. 

2. Voice Deal Confirm Requests 

Select this option to see confirmation request messages when a deal you are involved in 

requires counter party confirmation is added to the system. 

3. Voice Deal Confirm Notifications 

Select this option to see confirmation messages when a voice deal that you are involved in is 

added to the system and has been confirmed by both counter parties 

3.5.3.7 Sounds 

You can assign sounds to e.g. deal confirmation or delete price events. To change the sound 

settings, do the following: 

1. select the event you want to change the sound for in the Events list 

2. select a sound from the Sounds drop-down list. If you want to check the selected 

sound, you can listen to it by clicking (play). 

If the sound you would like to choose is not displayed in the list, click Browse to select any 

other sound file (in WAV format). 

 

3.6 Activity Ticker 

The Activity Ticker shows details of recent market activity, such as deals that have taken place, 

and orders being added, updated, dealt, and deleted. 

You can filter the information that is displayed in the Activity Ticker with right clicking on the 

Ticker so that it only shows the sort of information what you wish to see. 

 

3.7 Bank Holidays button 

By clicking on the Bank Holidays button (located at the upper left corner of the screen) the next 

upcoming bank holidays become visible on the trading screen. Please note, that Holiday block 

and Holiday individual day products are tradeable on the last business day preceding the bank 

holiday. 



   

 

 

 

By clicking on the Bank Holidays button the second time, the next upcoming Holidays will 

disappear from the trading screen again. 

Title 4 Series of Sessions 

 

 SPOT market PhF market 

HVP  

(Hungarian Virtual 

Point)  

Products 

NH 

(Next Hour); 

WD 

(Within-day) 

DA 

(Day-ahead, Weekend, 

Saturday, Sunday, 

Holiday)  

PhF market products: 

Months, 

Quarters 

(OTC trades) 

Locational 

Products 

NH  

(Next Hour);  

WD  

(Within-day) 

ND (Next Day) - 

Series of Session Open Open Closed 

Open  

(only CEEGEX 

weekdays) Closed 

0-24 
08:30:00 - 

03:00:00 

03:00:01 - 

08:29:59 

08:30:00 - 

16:30:00 

16:30:01 - 

08:29:59 

The sessions are visible for all instruments in gray boxes in the workbook. 

 



   

 

 

4.1 Open (Continuous Trading) Session  

During the Open (Continuous Trading) Session traders of CEEGEX Members may submit 

orders into the order book, which will match when bids and offers are equal or overlap in price. 

OTC trades can be reported for clearing. Cross trades are not permitted. 

4.2 Closed Session 

After the closure of the market, firm order entry, trading and OTC trade reporting are not 

permitted.  

4.3 Halt Session 

The Halt Session is an “override” session that can be scheduled by CEEGEX Ltd. instantly if 

necessary to close the market, for example in response to extraordinary market events. At the 

end of the Halt Session, the system can be quickly returned to the session that was in place 

prior to the halt. 

  



   

 

Title 5 Order types 

 

Type Explanation Example 

Firm (tradeable) 

Firm orders are the only tradeable orders in GlobalVision, and 

all GlobalVision users can see them (subject to permissions 

and trading agreements). Tradeable firm orders are shown in 

red by default. 

 

Fill and kill 

An order that will be dealt for whatever quantity is available, 
and then dropped. If there is not enough available quantity to 
satisfy the total requested quantity, the order will be partially 
dealt, and the remainder will be dropped. Fill and kill orders are 
shown in red like the tradeable firm orders. 

 

Withheld 

Withheld orders cannot be traded by anyone. They are only 

visible to exchange operators, and traders belonging to the 

company that owns the order. They are not visible to traders 

from other companies. By default, withheld orders are light 

grey. 

 

Hidden quantity/ 

Iceberg 

Only the visible quantity will be shown to other traders, with 

portions of the hidden quantity becoming visible and tradable 

automatically when the visible quantity has been dealt. 

 

Your own orders 
Your own orders (and orders belonging to your company) are 

shown with a green background by default. 
 

 

  



   

 

Title 6 Trading screen 

Order Handling 

6.1 Worksheets 

There are three worksheets on the trading screen:  

 CEEGEX worksheet: on this screen you can find all the Hungarian Virtual Point 

products: 

o Next-Hour and Within-Days 

o Day-ahead products 

o PhF products. 

 

 

 

 Locational worksheet: here you can find all the locational products of CEEGEX: 

o Next-Hour and Within-Days 

o Next Day product 

 



   

 

 

 OTC deal registration worksheet: here you can registrate your exsisting deal with your 

dealing partner. See more at section 6.15. 



   

 

 

6.2 Submitting an Order to the Market 

Below is a screenshot of the CEEGEX trading screen. The blue box highlights the tradeable 

area for the future contract Hungarian Virtual Point Nov-17 



   

 

 

To submit an order for this contract, you can either 

 double-click on the tradeable area, or 

 right-click on the tradeable area, and select “Add Order”  

Either way will bring up the “Price Entry Dialog”: 
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Below listed the fields that you need to fill in to add an order: 

1. Side  

Indicate whether it is a “Bid” or an “Ask” order. Depending on where you click to bring up the 

dialog, it defaults to “Bid” or “Ask” accordingly:  

 

2. Price 

3. Quantity 

4. Price Status 

Select a status for the price. It can be “Firm”, “Firm – Fill and Kill” or “Withheld”.  

Fill and Kill: an order that will be dealt for whatever quantity is available, and then dropped. 

5. Expiry Type 

Select an expiry type for the price. It can be “Good Till Cancelled”, “Good For Day” or “Good 

Till Date”.  

6. Hidden Quantity 

Submitting an order with a hidden quantity allows you to submit an order with a large quantity 

without initially revealing the full quantity to the market. 

7. Trading account 

It is not possible to add an order without adding a trading account. For the first time you need 

to add your account(s) to the scroll down menu by choosing <Edit…> and mark your accounts 

and click on Add. You can set the default account with the Move Up and Move Down bottoms. 

The account on the top will be the default. 



   

 

 

Having the above fields filled out, you can now click “Add” to submit the order. 

  



   

 

6.3 Viewing Order Details 

There are a number of ways to view the details of an order submitted to the system: 

 Mouse-over the order 

 

 

 Right-click on the order and then select “Investigate Order” 

 

   

  



   

 

6.4 Click-Trading 

The Front-End application enables you to deal orders by one or two clicks. For example, to 

deal the order Hungarian Virtual Point Nov-17 (Bid), you can either: 

 double-click on the order (anywhere inside the blue box), or 

 

 right-click on the order, and select “Deal Order”. 



   

 

 
  



   

 

Either way will open the “Deal Order” window: 

 

In the Deal Order window: 

1. select the total quantity to deal. This can be up to or equal to the quantity shown in the 

worksheet 

2. tick the box “I confirm that these details are correct. 

Finally, click either “Buy” or “Sell” (depending on the type of order you are dealing) to execute 

the deal. 

6.5 Auto-Matching 

When there are matching bid and ask orders in the market, trades will be executed 

automatically. 

Suppose that there is a bid order of Hungarian Virtual Point with price 17,00 and quantity 10. 

 

If you submit a matching ask order with price 17,00 and quantity 10 the two orders will be 

automatically matched, resulting in a trade. 

 

1 

2 



   

 

6.6 View Market Depth 

To view Market Depth right click on the instrument and select “View Market Depth”. By right-

click on the left hand corner of the Market Depth window you can select the following: 

 

6.6.1 Aggregate View 

This function aggregates the quantities for the same price. For example if there are two bid 

offers for a price of 17,40, one of them with 22 MWh/h and the other with 120 MWh/h quantity, 

the aggregated view will show these offers as one bid offer of 142 MWh/h quantity for 17,40 

price. 

 



   

 

6.6.2 Select Columns. 

You can customize your Market Depth window by selecting the columns which you wish to see 

in window. 

→  

6.7 View Deals 

You can use the Deals window to view the deals submitted to the system. To open the Deals 

window: 

 go to View → Deals or press F9 or 

 click on the  icon (on the top-right corner) 

 

If you would like to see information about certain deals and not every single deal, you can set 

the filters on the left of the Deals window; click “Apply” and the deals that match the filters you 

have set will be shown on the right. 



   

 

You can choose which columns of information to show by going to View → Columns, and then 

selecting the columns you would like to see: 

 

 

You can find three sheets on Deals window: 

 Current Deals: shows the executed deals  

 Unconfirmed Deals: shows the deals waiting for confirmation. For example you will see 

your OTC deals here until you or the other party will not confirm it. 

 Deleted Deals: lists all deleted deals in the selected period of time. 

Deals window will pop up by default after every deal which was made on the market, including 

OTC deals. In order to turn off the popup window do the following: 

Tools menu → Options → Deal confirmations → Popup deal notifications: None and click OK. 

 



   

 

6.8 Updating an Order 

Right-click on the order in the grid and select “Update Order” from the menu. Changing the 

order's quantity and expiry time can be made without affecting the order's position in the price 

stack relative to other orders with the same price value. 

6.9 Dealing a Single Order 

When you deal a single order you can only deal in quantities up to or equal to the amount 

shown in the Worksheet for that single order. 

1. To deal a single order, open the Deal Order Dialog by doing one of the following: 

 right-click on the order, and select Deal Order 

 highlight the order and press Enter 

 double-click on the order. 

2. In the Deal Order Dialog, select the required quantity. 

3. Select I confirm that the deal details are correct. 

4. To execute the deal, click either Buy or Sell (depending on the type of order you are 

dealing). Alternatively, click Cancel to close the Deal Order Dialog without making the 

deal. 

6.10 Join the Market 

Join the Market provides a quick way to enter an order that is similar to an order already in the 

market for the selected instrument and period. 

To join the market: 

 right-click on the price you want to match 

 select “Join the Market” from the right-click menu 

 Price Entry Dialog opens. 

6.11 Match the Market 

Works in the same way as join the market, except that new order defaults to the opposite side 

of the market to the one that you clicked on. 

6.12 Deleting an Order 

To permanently remove an existing order from the Worksheet, do one of the following: 

 right-click on the order in the grid and select “Delete Order” from the right-click menu 

 highlight the order and press DEL. 

If you just want to make an order untradeable, you can withhold the order, rather than deleting 

it. Withholding the order makes it untradeable, but keeps the order in the system so you can 

make it tradeable again at some point in the future. To withhold an order, select “Withhold 

Order” from the menu. 



   

 

6.13 Investigating an Order 

Investigate Order displays more detailed information about an order, such as additional terms 

or the last update. 

 

6.14 Market Movement Arrows 

The direction and colour of the arrow indicates the market movement (green arrows indicate 

that the last traded order was submitted to the ask side of the market, while red arrows indicate 

that the order was submitted to the bid side). 

 The last traded order was an ask and the price was higher than the trade before that. 

 The last traded order was a bid and the price was higher than the trade before that. 

 The last traded order was an ask and the price was lower than the trade before that. 

 The last traded order was a bid and the price was lower than the trade before that. 

 The last traded order was an ask and the price was the same as the trade before that. 

 The last traded order was a bid and the price was the same as the trade before that. 

 

  



   

 

 

6.15 Submission of OTC deals 

Deal Handling 

6.15.1 Submitting a Deal  

Please note that only exchange tradeable contracts can be registered as an OTC trade. 

Below is a screenshot of the Hungary worksheet. The blue box highlights the tradeable area 

for the future contract Hungarian Virtual Point Jan-18. 

 

  

To submit a deal for this contract right-click on the tradeable area and select “Add Deal”. 



   

 

 

Below find the list of fields you need to fill out in order to add a deal: 

1. Instrument 

Indicate whether it is a monthly or quarterly contract of the Hungarian Virtual Point product you 

wish trade. 

2. Deal Date 

You can set the date of the deal by clicking on the day, month and year separately and 

modifying it with the  arrows. 

3. Price 

4. Quantity 

 

5. Initiator Details 

Details of the party who indicated the buy or sell deal. 

 Broker Company: CEEGEX 



   

 

 Broker Name: <None> 

 Trading Account: choose your own account. If your account is not visible in the 

scroll down menu, you need to add it to the list. See in 6.1 menu. 

 Buy/ Sell 

 Crossing: self deal is prohibited on CEEGEX Physical Futures Market thus do 

not select crossing when adding a deal. 

6. Aggressor Details 

 Broker Company:CEEGEX 

 Broker Name: <None> 

 Trader Company 

 Trader Name 

6.15.2 View Deals 

Click the Deals icon  (on the top-right corner) or press F9 or right-click on the deal, and 

select “View Deals”. 

If you like to see information about certain deals and not every single deal in the system, you 

can set the filters on the left of the Deals window, click “Apply” and the deals that match the 

filters you have set are shown on the right. 

6.15.3 View Market Depth 

To see the full market depth for any instrument, right-click on the grid and select View Market 

Depth. 

6.15.4 View Deal Ticker 

You can open a scrolling deal ticker to see details of deals as they take place: the details of 

each deal are displayed in a small rectangular deal card, which scrolls across the screen from 

right to left. 

 

6.16 Notifications and warnings 

In order to minimize the possibility of mistrade, several checks were introduced to the trading 

system. These checks include warnings and notifications as follows. 

  



   

 

6.16.1  “Off the market price” warning 

In the following example a Bid is entered that would otherwise be dealt automatically.

 

Since the price of an order about to be entered is more than 5% off the market price, a small 

warning window pops up. 

 

You can ignore this warning by clicking on YES (Igen) and enter the order anyway, or click on 

NO (Nem) if you did not intend to enter the given price. 

6.16.2 Crossing the market  



   

 

Should you enter a Bid that is higher than the Best Ask (or an Ask that is lower than the Best 

Bid) a small warning window pops up. 

 

You can ignore this warning by clicking on YES (Igen) and enter the order anyway, or click on 

NO (Nem) if you did not intend to enter the given price. 

6.16.3 Sane price range 

There is a so called “sane price” range established in order to warn traders if they are about to 

enter an order that is significantly lower or higher than usual on the Hungarian market. The 

minimum sane price is 10 EUR, the maximum is 40 EUR. Should you enter a price that is 

outside of this range, a warning window will pop up. 



   

 

 

You can ignore this warning by clicking on YES (Igen) and enter the order anyway, or click on 

NO (Nem) if you did not intend to enter the given price.  



   

 

6.16.4 Minimum and maximum price range 

There is a minimum and maximum price that can be entered for a given instrument. The 

minimum price is 0,01 EUR, the maximum is 999. Should you try to enter a price that is outside 

of this range, a small notification window will pop up. 

 

 



   

 

 

Please note that it is not possible to ignore this warning; you will not be able to enter a price 

outside of this specified range. 

6.16.5 Minimum and maximum quantity range 

There is a minimum and maximum quantity that can be entered for a given instrument. The 

minimum quantity is 1 MWh/h, the maximum is 10 000 MWh/h. Should you try to enter a 

quantity that is outside of this range, a small notification window will pop up. 

 

Please note that it is not possible to ignore this warning; you will not be able to enter a quantity 

outside of this specified range. 

  



   

 

Title 7 Shortcut keys 

7.1 Trading shortcut keys 

You can use the following keys during trading. 

Key Action 

DEL  Deletes the selected order (provided it is either your own order, 
or an order that you have permission to delete).  
 

Enter  Opens either the Deal Price dialog box or the Price Entry dialog 
box, depending on the currently selected cell:  
Tradable order Opens the Deal Price dialog box to deal the 
order.  
An order that you have permission to modify (for example 
one of your own orders) Opens the Price Entry dialog box to 
modify the order.  
Empty cell Opens the Price Entry dialog box to add a new 
order.  
 

Insert  Opens the Price Entry dialog box to add an existing order for the 
selected instrument. 
  

* (numeric keypad)  Opens the Price Entry dialog box to modify the order (provided it 
is either your own order, or an order that you have permission to 
update).  
 

+ (numeric keypad)  Opens the Price Entry dialog box to add a new order.  
 

/ (numeric keypad)  Opens the Price Entry dialog box to join the market.  
 

- (numeric keypad)  Deletes the selected order (provided it is either your own order, 
or an order that you have permission to delete).  
 

SPACE  Investigates the selected order.  
 

Alt+D  Opens the Deal Price dialog box to deal the order.  
 

Alt+B  Adds the selected order to the Deal Basket.  
 

Ctrl+H  Opens the Orders window to show the selected order's history.  
 

Ctrl+F  Firms the selected order or orders.  
 

Ctrl+W  Withholds the selected order or orders. 
  

Ctrl+A  Selects all orders in the Order Book (or selects all cells on the 
grid in the Front-End).  
 

F3  Opens the Market Depth window.  
 

F2  Opens the Price Entry dialog box to insert a bid order for the 
instrument in the currently selected cell.  
 

F12  Opens the Price Entry dialog box to insert an ask order for the 
instrument in the currently selected cell.  
If the Price Entry dialog box is already open, then this shortcut 
sets the side of the market to Ask.  
 



   

 

 

7.2 Navigation shortcut keys 

You can use the following keys at all times to navigate the Work Sheet. 

Key  Action  

Cursor Keys  Move the active cell left, right, up, or down.  

 
Home  Move to the furthest left cell in the current row.  

 
End  Move to the furthest right cell in the current row.  

 
Ctrl+Home  Move to the top left corner of the grid.  

If the currently selected cell is part of an Activity Ticker object or 
an Instrument Group object, this shortcut instead scrolls to the top 
of the object.  

 
Ctrl+End  Move to the bottom right corner of the grid.  

If the currently selected cell is part of an Activity Ticker object or 
an Instrument Group object, this shortcut instead scrolls to the 
end of the object.  

 
Page Up  Move up the grid one page.  

If the currently selected cell is part of an Activity Ticker object or 
an Instrument Group object, this shortcut instead moves up the 
object by one page.  

 
Page Down  Move down the grid one page.  

If the currently selected cell is part of an Activity Ticker object or 
an Instrument Group object, this shortcut instead moves down the 
object by one page.  

 
Ctrl+Cursor Keys  Move to the furthest left, right, top, or bottom cell in the grid.  

 
Tab  Move to the next cell on the right.  

 
Shift+Tab  Move to the cell on the left.  

 

 

 


